Back to overview
Degraded

Partial Service Disruption

Jan 20 at 12:29pm CET
Affected services
Sign Maker
Web Admin
Websites

Resolved
Jan 20 at 01:20pm CET

We have identified the issue and provided a fix.
We will closely monitor the uptime.
Thanks for your patience.

Created
Jan 20 at 12:29pm CET

We are currently experiencing a partial service disruption affecting some platform features. Our team is actively investigating and working to restore full functionality. We will provide updates as more information becomes available.