Back to overview
Downtime
Experiencing sites not responding
Oct 13, 2023 at 6:26pm UTC
Resolved
Oct 13, 2023 at 8:35pm UTC
All sites are back up and running as expected
Affected services
Updated
Oct 13, 2023 at 7:23pm UTC
We have made some adjustments and sites are responding faster now. Still monitoring
Affected services
Updated
Oct 13, 2023 at 7:08pm UTC
We are still working on recovering the sites that are affected by this incident.
Affected services
Created
Oct 13, 2023 at 6:26pm UTC
We are currently investigating an issue causing sites not responding.
We will keep this incident updated with our investigations.
Affected services